What a day...

Monday, December 30, 2013 4:14 PM UTC

Short term: I'm currently working on a project since 3 months or so, now the final stage is entered. But there were problems in the customer's environment, e.g. with browser access to the application. The browsers that are used here are Internet Explorer 8 and (!) Google Chrome 21.someting (!!). Now the funny part upon some of the issues I had last week and solved today, maybe you can learn from it, too (as I did today):

  • Problem no. 1: Chrome won't display an anchor afterwards an input element. Anchor was created via Vanilla Javascript DOM element methods.
    Though the CSS was correct it appeared that Chrome did not show the anchor element right next to the input element. Both elements reside within a TD element and the space was fairly enough though. I solved the problem by setting the float of the input to "left" and of the anchor to "right" - so now both reside besides each other. The stupid thing: in IE8 everything was fine... Albern
     
  • Problem no. 2: the anchor from no. 1 should bring up a jQuery dialog displaying a custom name picker (no Xpages, no Extlib here...). The namepicker was filled by a Lotusscript agent that responses XML data which is parsed by CSJS to HTML nodes. The content type is set to "text/xml", the charset is set to "ISO-8859-1" as we deal with German signs. In my test VM with the same version of IE8 installed - no problem with that (using the jQuery ajax method), customer's IE fucked up, saying no error message and stuff. WTF? Solution: keep in mind that if you set your encoding/charset to the response header of your agent output, you better use the parameters "dataType" set to "xml" AND (and that's the important part) set parameter "contentType" to exactly the type you produce in your agent, e.g. "text/xml; charset=ISO-8859-1" as the value. That did the trick here.
     
  • Problem no. 3: Vertical align of input fields with "height"-CSS-attribute: forget about it using Chrome, you won't find a suitable solution, maybe some hacks, but NO solution! This bug was reported long ago but was never fixed. So if you want to use an inputfield with a height set so an amount of e.g. 200px just leave it alone. Use a textarea instead and you won't face any trouble.

That's it from me this year, I close my working year with these lessons learned today. I can now face the end of the year w/o any worries about the project anymore as I solved all the problems today (including a 2x220km travel to the customer). Though I have to work tomorrow for 4h and wait for some callers on our support hotline (no one will ever call us tomorrow #grmpf...) I feel my working year ended TODAY!

So have a nice party tomorrow, keep safe and please don't buy fireworks - just watch/hear the stuff others bought with their money. Maybe you can adapt my XMas party suggestion for you?

Take care & see you "next year" L├Ąchelnd






Leave a comment right here