Domino 10 on Ubuntu 16.04 LTS

Monday, October 15, 2018 7:26 PM UTC

This is not a supported OS, I know. However, I always installed Domino on Ubuntu and it worked like a charm - for development machines, my homepage, test servers - no problems at all.

With V10 things changed a bit. When using Ubuntu locally I always used the latest server OS which now is 18.04 LTS - and it worked without any problem. I installed all the betas on it directly without anything added to the OS. 

Things to consider

If you want to make sure V10 installs properly you have to make sure a few things:

  • set the locale to en_US.UTF-8 (probably a bug, thanks to Lars for the headsup)
  • install the package „bc“

On 18.04 this worked as expected, even the silent (pds) way worked (except from a problem I had when trying to connect to the „first“ server from the VM via the hostname, which is dynamic. Using a static IP though worked.

However, on my hosting service - which only offers 16.04 - this didn’t work. I have no idea why. I managed to copy all the stuff from a 16.04 VM (server and proton worked!) to the host and even started the server but with some downsides:

  • no messages in the console available, only timestamps
  • I wasn’t able to quit the server with the „q“ command
  • even after I stopped the server „the hard way“ it was available from a client - very weird
  • the proton addin did not load at all, also no http task

This is not a beta anymore and Ubuntu is not supported. But as I hate CentOS/Redhat I’ll have to wait until my hosting provider updates the vserver templates to 18.04. The vserver also behaves completely different regarding the installation of Docker which was my other option - no luck.

Conclusion

I guess I have to wait until the end of the month when the Windows version of the proton addin will be available. Though I also hate Windows this might turn out better in this case - at least for me.





Latest comments to this post

Lars Samuelsson wrote on 16.10.2018, 06:30

It’s reported to IBM and HCL through discussion and email.

I have not had time to be part of a beta so I have not reported it in any beta forum.

 Link to this comment
Oliver busse wrote on 16.10.2018, 00:08

Lars, I don't quite get what you mean. What are you looking for?

 Link to this comment
Lars Berntrop-Bos wrote on 15.10.2018, 23:56

I had to install the bc package on my CentOS 7.5 Core before I could install Domino 10 final.

I searched for the headsup by my namesake, but couldn't find it in the beta forum.  Is it in a public place or only in private?

 Link to this comment

Leave a comment right here