Quick-Tip: Solving issues with Feature Pack Installers on Linux

Wednesday, July 25, 2018 10:40 AM UTC

Due to the fact that I am forced to upgrade one of the servers to FP8+ (FP10 in this case) I stumbled upon a problem with the install script (btw: this is still declared as from 1999…)

I already knew the issue with unsupported Linux systems like Ubuntu server (the Perl problem described here) and how to fix them. This one was new.

The first problem after extracting all files and running the install script was this message:

This is an Linux 64 Domino install kit, please use Domino kit for Linux32 platform

Beside from the grammar mistake in the phrase itself, this is totally misleading as I am running a 64bit Linux system.

The problem is the script that determines which OS is used. The simple fix is to skip all the crap in the if-then-else part and set the NUI_ARCH variable manually afterwards. Find line 123 in the script directly after the if-fi block and insert these lines:

# we don't care
NUI_ARCH=linux64
export NUI_ARCH

This tells the installer that the system is Linux 64bit in a static way.

My next issue was that the installer complained about the missing environment variable NUI_NOTESDIR. I did set it manually like the message suggested

NUI_NOTESDIR=/opt/ibm/domino/

export NUI_EXPORT

but the installer kept complaining. The reason was just that there was a file missing in that path:

.install.dat

I don’t know why this file was missing, but I really don’t care. One solution is to re-install a base server on the existing one (not an option if you ask me) or to grab this file (no matter what’s inside) from another running Domino on Linux 64bit. The latter was my solution and thanks scp I was able to grab it directly from another host.

After that was done the script executed just fine and I was able to install FP10 - which I may regret, but I need it to run LE4D v2 on this machine.

Update

Yes, I regret it as the HTTP server didn't load after the upgrade with the following error:

JVM: The JVM runtime library could not be found.

Now for the downgrade... thanks for nothing.

Update 2

Interesting fun fact: after downgrading (removing FP10) the server didn't start up at all, so I re-installed the base 9.0.1 package and then FP8 on top. Interestingly the HTTP task is running and I can access everything but it doesn't show up in the task list using show server. Any ideas on this phenomenon?






Leave a comment right here