Solved a problem with the Domino Update Site

Friday, March 18, 2016 10:03 PM UTC

A few hours ago I arrived back home from the "WebGate Super Day" anniversary party event in Dietikon, Switzerland (near Zürich) where WebGate has it's headquarters. I won't provide details but this was a great event. It occured that I had almost two full work days before and afterwards so I spent some time with the guys from WebGate in their "holy halls". Thanks for your hospitality!

Today I also spent some time with Christian Güdemann, our OpenNTF chairman setting up and tweaking my machine for some future projects. I always failed to setup Eclipse to work properly (I don't like it that much and it doesn't like me either). After some tweaking I was able to do what I wanted. Anyway, I stumbled upon a problem I had for almost a year now:

I was not able to import a local update site into my update site database on my local development server I got pre-installed on my machine when I joined We4IT. Everytime I wanted to import a local update site to the database using my local server the client freezed instantly without producing any error logs. I was able to perform that operation on other servers in my home network (with a replica of that update site database). Strange enough...

Christian pointed me to the obvious: the ECL. The reason for that behavior was that my local server wasn't in my ECL. I don't know why but I never thought about that as all the other machines I am working with are in fact in the ECL - with all rights. Even my user ID was setup correctly to perform any of those operations. 

Adding the server explicitly to the ECL and setting up all rights for it solved to problem. Way too simple, right?

Thank you, Christian for the headsup! L├Ąchelnd

By the way: I strongly recommend the latest version of the Open Eclipse Update site from OpenNTF as it provides some other interesting ways to incorporate extensions to your environment.






Leave a comment right here